用語集サイトマップ
topics

 マイクロソフト社のセキュリティ修正プログラムについて(MS12-017,018,019,020,021,022)2012年03月14日

平成24年3月14日
警察庁

マイクロソフト社のセキュリティ修正プログラムについて(MS12-017,018,019,020,021,022)

 マイクロソフト社の製品において、意図しないプログラムを実行されるなどの脆弱性が発見されました。
 この脆弱性は、マイクロソフト社により定義された4段階の深刻度評価のうち、最上位の「緊急(Critical)」が含まれていますので、該当するプログラムを使用している場合は、今後の被害防止のために以下の対策を行うことをお勧めします。

1 概要

(1) DNS サーバーに脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、サービス拒否が起こる可能性があります。(MS12-017)
(2) Windows カーネルモード ドライバーに脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、特権の昇格が起こる可能性があります。(MS12-018)
(3) DirectWrite に脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、サービス拒否が起こる可能性があります。(MS12-019)
(4) リモート デスクトップに脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、リモートでコードが実行される可能性があります。(MS12-020)
(5) Visual Studio に脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、特権の昇格が起こる可能性があります。(MS12-021)
(6) Expression Design に脆弱性があります。攻撃者によりこの脆弱性が悪用された場合、リモートでコードが実行される可能性があります。(MS12-022)

2 脆弱性を有するソフトウェア

 マイクロソフト社の情報によると、脆弱性の問題があるバージョンは以下のとおりです。

上記(1)の脆弱性

  • Windows Server 2003 Service Pack 2
  • Windows Server 2003 x64 Edition Service Pack 2
  • Windows Server 2003 with SP2 for Itanium-based Systems
  • Windows Server 2008 for 32-bit Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 for x64-based Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 R2 for x64-based Systems および Windows Server 2008 R2 for x64-based Systems Service Pack 1
    (Server Core インストールは影響を受けます。)

上記(2)の脆弱性

  • Windows XP Service Pack 3
  • Windows XP Professional x64 Edition Service Pack 2
  • Windows Server 2003 Service Pack 2
  • Windows Server 2003 x64 Edition Service Pack 2
  • Windows Server 2003 with SP2 for Itanium-based Systems
  • Windows Vista Service Pack 2
  • Windows Vista x64 Edition Service Pack 2
  • Windows Server 2008 for 32-bit Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 for x64-based Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 for Itanium-based Systems Service Pack 2
  • Windows 7 for 32-bit Systems および Windows 7 for 32-bit Systems Service Pack 1
  • Windows 7 for x64-based Systems および Windows 7 for x64-based Systems Service Pack 1
  • Windows Server 2008 R2 for x64-based Systems および Windows Server 2008 R2 for x64-based Systems Service Pack 1
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 R2 for Itanium-based Systems および Windows Server 2008 R2 for Itanium-based Systems Service Pack 1

上記(3)の脆弱性

  • Windows Vista Service Pack 2
  • Windows Vista x64 Edition Service Pack 2
  • Windows Server 2008 for 32-bit Systems Service Pack 2
    (Server Core インストールは影響を受けません。)
  • Windows Server 2008 for x64-based Systems Service Pack 2
    (Server Core インストールは影響を受けません。)
  • Windows 7 for 32-bit Systems および Windows 7 for 32-bit Systems Service Pack 1
  • Windows 7 for x64-based Systems および Windows 7 for x64-based Systems Service Pack 1
  • Windows Server 2008 R2 for x64-based Systems および Windows Server 2008 R2 for x64-based Systems Service Pack 1
    (Server Core インストールは影響を受けません。)
  • Windows Server 2008 R2 for Itanium-based Systems および Windows Server 2008 R2 for Itanium-based Systems Service Pack 1

上記(4)の脆弱性

  • Windows XP Service Pack 3
  • Windows XP Professional x64 Edition Service Pack 2
  • Windows Server 2003 Service Pack 2
  • Windows Server 2003 x64 Edition Service Pack 2
  • Windows Server 2003 with SP2 for Itanium-based Systems
  • Windows Vista Service Pack 2
  • Windows Vista x64 Edition Service Pack 2
  • Windows Server 2008 for 32-bit Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 for x64-based Systems Service Pack 2
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 for Itanium-based Systems Service Pack 2
  • Windows 7 for 32-bit Systems および Windows 7 for 32-bit Systems Service Pack 1
  • Windows 7 for x64-based Systems および Windows 7 for x64-based Systems Service Pack 1
  • Windows Server 2008 R2 for x64-based Systems および Windows Server 2008 R2 for x64-based Systems Service Pack 1
    (Server Core インストールは影響を受けます。)
  • Windows Server 2008 R2 for Itanium-based Systems および Windows Server 2008 R2 for Itanium-based Systems Service Pack 1

上記(5)の脆弱性

  • Microsoft Visual Studio 2008 Service Pack 1
  • Microsoft Visual Studio 2010
  • Microsoft Visual Studio 2010 Service Pack 1

上記(6)の脆弱性

  • Microsoft Expression Design
  • Microsoft Expression Design Service Pack 1
  • Microsoft Expression Design 2
  • Microsoft Expression Design 3
  • Microsoft Expression Design 4

3 対策

 マイクロソフト社のサイト(4 関連サイト参照)から適切なパッチをダウンロードし、適用してください。
 パッチの適用作業は、利用するアプリケーションへの影響を考慮した上で行ってください。

4 関連サイト